Not yet a SSCA member?
  • Twelve monthly issues of SSCA Commodores' bulletin
  • Members only website resource
  • Access to cruising stations around the world
  • Regional activities, games and much more!

Hi guy, I have a question, please help

Sails/Engines/Fuel/Refrigeration/Watermakers/Pumps/Heads

Hi guy, I have a question, please help

by tranha1 » Fri Feb 09, 2018 8:26 pm

:cry:
Occasionally when I change oil on my Universal M35-a diesel there will be little or no evidence of oil in the filter. This happens sporadically and with both Universal and other brands of filters. My oil pressure runs from about 40 when cold to 25-30 after a day of motoring. I've posed the question to Universal/Westerbeke but no answer yet. I'm on Seros in the Aegean so getting a mechanic to answer the question would be difficult. Thanks for any suggestions. :shock:
OFFLINE
tranha1
Posts: 1
Joined: Thu Feb 08, 2018 1:54 am

Re: Hi guy, I have a question, please help

by HartleyGardner » Sun Mar 04, 2018 12:36 pm

Hi tranha,

In an engine, there is a bypass valve that directs oil around the oil filter in case it becomes clogged - it is possible that yours is stuck open, which would lead to the problem you are having.

Hartley
S/V Atsa
OFFLINE
HartleyGardner
Posts: 7
Joined: Thu Apr 21, 2016 8:33 pm
Vessel Name: Atsa
Vessel Make and Model: Tayana 48DS

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests

Most users ever online was 177 on Wed Jan 30, 2013 9:10 am

Users browsing this forum: No registered users and 4 guests

Legend: Administrators, Global moderators, Registered users